Create A New Main Menu Category

The File option on the main menu is an example of a category. Keep the following standards in mind:

Create A New Main Menu Category

  1. Start the application.
  2. Select Desktop » Customize from the main menu.
  3. Examine the main menu.
  4. Move the mouse over the Help category but do not left click the category name.
  5. Right click over the category name and select Clone from the listed options.

    This clones the Help menu.

    This is a picture of the main menu.
  6. Right click over the new Help category.

    This displays the customize command menu.

    This is a picture of the main menu.
  7. Select Button Appearance from the listed options.

    This displays the button appearance dialog.

    This is a picture of the main menu.
  8. Set button text to &Modify. Include the ampersand ( to set the ALT + accelerator ).
  9. Click OK or hit ENTER when you are finished.

    The main menu looks like this: This is a picture of the main menu.

  10. Left click the Modify option and drag it to the left of the Help option.

    The main menu looks like this: This is a picture of the main menu.

Add Commands To The Category

  1. Examine the customization center.
  2. Find the Transform Commands Category. This is a picture of the main menu.
  3. Drag the command named SetModeInteractiveTranslate over the Modify option.
  4. When the menu appears, quickly drag the command into the first position on the menu and release the left mouse button. This is a picture of the main menu.
  5. Repeat the procedure and drag the SetModeInteractiveScale and SetModeInteractiveRotate commands onto the menu. This is a picture of the main menu.
  6. Right click on each of the remaining commands ( the commands below SetModeInteractiveRotate and select Delete from the listed options.

    This cleans up the menu by removing the existing commands.

    This is a picture of the main menu.

Set Command Names

  1. Right click over the command named SetInteractiveTranslate.
  2. Choose Button Appearance from the listed options.
  3. Set the button text to &Translate.
  4. Click OK when you are finished.
  5. Right click over the command named SetInteractiveScale.
  6. Choose Button Appearance from the listed options.
  7. Set the button text to &Scale.
  8. Click OK when you are finished.
  9. Right click over the command named SetInteractiveRotate.
  10. Choose Button Appearance from the listed options.
  11. Set the button text to &Rotate.
  12. Click OK when you are finished.
  13. Find the Transform Commands Category. This is a picture of the main menu.
  14. Examine the customization center and click Close.

    Provided a selection is active, these commands are now active and accessible by mousing over the menu and choosing an option or by using ALT+M+T, ALT+M+S, or ALT+M+R. Go ahead and test these commands.

Delete The Modify Menu

  1. Select Desktop » Customize from the main menu.
  2. Right click over the Modify menu and select Delete from the listed options.
  3. Shut down the application and restart.